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Extrusion

Extrusion is one of the most basic operations in 3-D
modeling but, also one of the most useful. This tutorial is a step-by-step
tour to help you quickly familiarize yourself with the Extrude, Path
Extrude, and Bevel Extrude tools, and access each of their special
features. For more detailed reference information regarding these tools,
consult the Tool Palette chapter. ModelPro 3.0 also incorporates an 
on-line Help feature located under the Apple Menu.

Part I - Creating a Simple Extruded Object

Extrusion is the process where a 2-D contour is given
depth, literally making a 3-D shape. More complex forms of extrusion
involve rotation and offset to create organic shapes. In this example, you
will create a box out of a rectangle

Getting Started

Launch ModelPro by double-clicking on its icon.
Observe that ModelPro automatically opens a New blank file
upon launch. Your double-width Tool palette is on the left; your
Snap Palette is directly below the Tool palette; your Groups
palette is on the right over the 3-D preview window titled
Angled; counter-clockwise from top-left are your Top View, Front
View and Right View drawing windows; at the top of the screen is
the Tool Info Palette, and at the bottom of the screen is the
Status Line palette.

In this part of the tutorial, you will use the Rectangle and Extrude
tools. These tools and the tools you will be using in other parts of
this tutorial are shown in the accompanying diagram of the Tool
palette. Take a minute to review their names and locations.

Preparing the Drawing Environment

Under the Edit menu choose Preferences to
display the General dialog. The box next to 3-D Operations
Create Folders should be checked. If not, click in the box and
click in the OK box. If checked, just click in the OK box. This
cause any object created by a 3-D operation like Extrude to be
place in a folder.
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Note: Most of the 2-D tools can be
selected by typing the letter that is in
the lower-right hand corner of the icon.
The 3-D operations can be selected by
holding the Shift key down and typing
the similarly designated letter.
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In order to leave a clear view of the Angled Window, compress the
Groups Palette by clicking in the Zoom box located at the upper-right
corner of the Palette. This will leave the Palette visible (compressed) 
on screen, and readily available again by clicking in the Zoom box.

Draw a Rectangle

Click on the Rectangle Tool icon in the tool palette. 
To draw the rectangle, click in the top, left of the Top View and drag
down and to the right. Release the mouse.

ModelPro automatically names and adds all elements drawn or created
to the Groups palette. While you may never have to use the Groups
palette, it comes in handy for efficiently handling large, complex objects.

Extrude the Rectangle

Select the Extrude tool from the tool pallet. (If your 
2-D contour(s) is not still selected re-select it now using the Selector tool).

Notice that an Extrude Tool Info palette is displayed above the windows
and control points appear in all the windows. These will be explained
later. For now, click on the Extrude Button in the Extrude Tool Info
palette or double click within any drawing window. 

Click on the Smooth-shaded Display button in the  3-D Window to
preview your object. You have just created a simple extrude object using
ModelPro’s Default Extrusion Settings.

Look at the Groups palette. You will notice a closed folder titled 
Extrude 1. Click on the folder arrow at the immediate left of the folder.
This causes it to open and display one object titled Extrude Mesh 1.

The Drawing Options portion of the Tool palette lets you select 
the drag options for 2-D contours. The default option is drawing 
corner-to-corner. 

Color Preferences dialog

Note: Preferences gives access to
dialog boxes for entering numeric
information and choosing options to
fine-tune the ModelPro interface. The
Preferences dialog boxes are: General,
Screen, Drawing, Grid, and Colors.
Drag the slider at the left down to
expose the Colors Preferences dialog.

General Preferences dialog

Top view with rectangle

ExtrudeTool Info palette
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ModelPro provides you with prompts to let you know what step is
expected next. These prompts appear in the Status Line palette located
ate the bottom of the screen.

Extruding Other Shapes

Try extruding other contours created with any of the
other 2-D drawing tools. Try extruding a contour(s) in the Top and
Right View windows.

To reverse a step, choose Undo under the Edit Menu.

To change the size of an object, select the Selector Tool and hold down
the option key and click on the object or just click on the name of the
object in the Groups palette. Four dots representing a bounding box will
appear. Click, hold, and drag on any dot to re-size the object.

To edit a shape, select the Selector Tool or hold down the Command key
and click on the object, click, hold, and drag any of the points that are
highlighted to change the shape.

To edit a shape that is in a closed folder, either open the folder or use the
Direct Selector Tool which is on the Selector Tool pop-up.

To move an object, select the Selector Tool , hold down the Option key
and click, hold, and drag to the desired position.

The Angled View can be used to select points that are hidden in the
Front, Top, or Right views.

Refer to Chapter Four for a definition of the standard keyboard
modifiers.

Save often when working on a project, and make backup copies using
the Save and Save As commands from the File Menu.

Closed folders

Prompt Current cursor position

Note: To return to the spline display,
click on the Spline Display button in the
3-D Window.

Shaded cube

Open folders

Note: The newly created object ,
Extrude Mesh 1, was placed in a 
folder because the  3-D operations
Create Folders option was checked 
in the General Preferences dialog.
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Part II - Creating Extruded Objects Using Custom Tool Settings

In the previous example you created an extrude object
using ModelPro’s default extrusion values. These settings provide a
general starting point for extrusion operations, and can be used to
quickly generate 3-D objects. For more specific tasks, however, ModelPro
allows you to set custom values for the Extrusion Tool’s parameters.
These custom values can be set using either ModelPro’s Interactive
Controls or specific Numeric Input.

Getting Started

In this example, you will use the Rounded Rectangle
and the Extrude tools with its custom tool settings to twist and re-shape
the extruded rectangle. If you are not in ModelPro, launch ModelPro by
double-clicking on its icon. Create a new document by selecting New
under the File menu.

Preparing the Drawing Environment

In this part of the tutorial, we want direct access to all
objects and do not want them place automatically in a folder after a 3-D
operation. Select the Edit menu and choose Preferences to display the
General dialog. The box next to  3-D Operations Create Folders should
be un-checked. If it’s checked, click in the box and click in the OK box.
If it’s un-checked, click in the OK box.

In the Top Window you are going to create a rounded square drawn out
from the center. First, select the center to-corner option in the Drawing
Options portion of the Tool palette. Click and hold on the Rectangle
Tool icon in the Tool palette. Drag over to the Rounded Rectangle Tool,
the Second one in the pop-up, and release. To draw the square, while
holding the Shift key down, click in the center of the Top View and drag
away from the center. Release the mouse when the rounded square
nearly fills the window.

Using Extrusion Control Handles

Select the Extrusion Tool from the Tool Pallet. Notice
the preview copy displayed in the Angled Window and the Extrude
Tool’s intuitive control handles shown in the Top/Front/Right View
windows only. 

Tip: After completing a 3-D operation
like an Extrude, you may decide that
you want to change the shape and
extrude again. ModelPro provides you
with the ability to change your design
with some basic edit capabilities. You
can use the multiple level Undo
capability to reverse your operations,
the scaling capability to re-size the
object, and vertex editing to change
the shape of the object.
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To ensure that everything will be visible in all of the View windows,
hold the Command key and click in the Fit to Window box in any 
View window (left-most button at the bottom of Top/Front/Right 
View windows).

Setting the Depth and Direction of Extrusion

In the Front View click-drag on the triangular control
handle centered with the preview copy of your contour. This control
handle sets the depth and direction of an extrusion. The line extending
between the contours serves as a visual guide in establishing the settings
for these parameters. Move the control handle up and to the right. 

Setting the Scale of the End of the Extrusion

In the Top View window click and drag one of the four
triangles located at the corners of the preview copy of your contour.
These handles control the relative scale of the preview copy of your
contour. By clicking on and dragging any of these triangles you can
modify the scale of the preview copy in one or both dimensions. This
feature allows you to create objects that widen or narrow as they extrude
into 3-D space such a funnel or a megaphone. Notice the preview copy is
re -drawn as you move the control handles. Drag the lower right control
handle inward to reduce the size of the preview copy. 

Note: The Shift key constrains objects
like ellipses, rectangles, and other
polygons to circles, squares and
regular shapes.

Note: Clicking in a Fit to Window box
re-sizes the objects to fit in that
window. Holding the Command key
while clicking in any Fit to Window box
re-sizes the objects in all windows.

Extrusion Control Handles
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Setting the Rotation of the End of the Extrusion

While still in the Top View drag one 
of the four circles (one on each edge of the preview copy).
Drag in any direction to rotate the preview copy. As you
rotate the preview copy notice the Rotation Value 
changing in the Tool Info palette. This number represents the
numeric value for the Extrusion parameters you are modifying
intuitively.

Notice that the rotation is about the center triangle. 

Double click in the “rot°” box in the Tool Info palette at 
the top of the screen. From the keyboard enter the value
“45”. Notice that the screen updates to reflect the new 
value you have entered. In this manner ModelPro allows 
for precise input of a numeric value for each of the Extrude
Tool’s parameters. You can use any combination of numeric 
and interactive input to establish the parameters for the
Extrude Tool. All of the Extrude Tool’s parameters can be
established using either method, with the exception of the
Segment parameter. The Segment parameter must be 
input numerically.

Extrude the Rounded Square

Click on the Extrude button or double click in any
window to create the extruded object based on the parameters you have
just established. You will notice that the object is twisted and tapered.

Go to the File Menu and select Save AS. At the prompt for a name, type
Extruded Base.mdl. You can now quit or continue on to the next part.

ModelPro will remember the most recent values for a tool’s parameters.
This feature is useful for creating a series of objects based on different
contours with the same parameter values applied.

To reset a tool’s parameters, hold the Option key while selecting the tool
icon from the Tool palette. The ability to override a tool’s currently set
parameters is useful when undoing a  3-D operation. It allows you to set
new parameters for the operation.

Rotated contour

Contour control handles
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ModelPro allows you to extrude multiple contours simultaneously. To
select multiple contours Shift-select the desired contours to be extruded.

Contours can be selected before or after activating the Extrude Tool.

Additional contours can be added
to an active selection by Shift-
selecting. 

To deactivate the Extrude Tool
without performing an extrusion,
click on the Selector Tool icon.

Select Re-display under the
Windows menu whenever you
want to see the result of an
operation. To save time waiting 
for screen refresh, some actions 
and operations do not
automatically re-display. 

Extrusion Tool Info palette

Final Extrude

Note: The segment parameter defines
the number of segments the extruded
part contains. The default is one segment.
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Part III - Using “ribs” to Extend an Extruded Object

The results of 3-D operations on 2-D contours, like
Extrude, create a series of connected splines that form a 3-D object. One
or more of these splines can be selected as “ribs” by ModelPro and used
for performing additional 3-D operations.

Extruding a Rib

ModelPro allows you to select one or more splines
generated in a 3-D operation as a “rib”. These ribs can be used as 3-D
contours for other 3-D operations. In this example, you will select the
end of the extruded rounded rectangle created in Part II as the rib and
use it to perform another extrusion.

If you are not in ModelPro, launch ModelPro by double-clicking on its
icon. Go to the File Menu and Open Extruded Base.mdl

Preparing the Drawing Environment

To continue the extrusion process using the previously
created 3-D object, we will need to re-adjust the scale of the windows. In
the Front View, move the cursor to the Zoom out icon, click, and hold
until the object has shrunk slightly in size. Use the Hand Tool to move
the object down near the bottom of the window.

Select the Rib and Extrude

In this part we will use the rounded rectangle lying at
the end of the previous extrude, the “rib”, as the contour to be extruded.
Selecting a “rib” is a two step process. First, use the the Selector Tool to
select the extruded object and show its vertices. If the four bounding box
control points appear instead of the vertices, it means you have selected
the object instead of the vertices. This occurs when the object to be
selected is inside a closed folder. You need to open the folder and select
again or use the Direct Selector Tool. It is located on the pop-up next to
the Selector Tool.

Second, while holding down the Control key, click, hold, and drag a
small rectangle around the top part of the extruded object in the Front
View as shown. This selects the top rounded rectangle as the “rib” to be
used in the next step of the extrusion.

Note: Note to access the Direct
Selector Too,l type D or click and 
hold on the Selector Tool to get the
pop-up and drag over to the end of 
the pop-up.
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If you are continuing directly from Part II, hold the Option
key down to reset the Extrude parameters and select the
Extrude Tool from the Tool pallet. Otherwise, just select the
Extrude Tool from the Tool pallet. 

This is a good time to re-size the object in all views. Hold the
Command key down and click in any window’s Fit to
Window icon.

Click on the Extrude button on the Extrude Tool Info
palette, or double-click, to complete the extrusion.

Go to the File Menu and select Save As. At the prompt for a
name, type Extended Base.mdl. You can now quit or continue
on to the next part..

Note: Rib selection is a very powerful
feature of ModelPro. It enables you to
create some very exotic and complex
shapes. Any spline segment or groups
of spline segments can be selected for
3-D operations. By holding down the
Control key, the Selector Tool
becomes a “rib” Selector which can
select any generated 3-D spline for use
in further 3-D operations. For proper
use, the vertices must be showing so
they can be selected.

Select the rib

Extrude preview

After Extruding the Rib
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Notes


